Back to overview
Downtime

Several issues that are directly affecting our services

Mar 18, 2026 at 9:15am UTC
Affected services
Auth
Images

Resolved
Apr 14, 2026 at 3:11pm UTC

We have indentified the root cause of the Fused issue. It will be resolved within 10-15 minutes. Thanks for your patiente!

Updated
Mar 23, 2026 at 6:49am UTC

Most of our services have now fully returned to normal operation. However, a small number of users may still experience issues with authentication and account access.

Our team is actively working to resolve these remaining cases as quickly as possible. We sincerely appreciate your patience and understanding.

Updated
Mar 20, 2026 at 10:14am UTC

Update: Many of our services have now returned to stable operation. However, we are still experiencing some ongoing issues that may affect certain features—such as image delivery (CDN)—and some users may encounter difficulties accessing their accounts.

Our team continues to actively work on resolving these remaining problems and restoring full functionality as quickly as possible. We appreciate your patience and understanding while we complete these fixes.

Created
Mar 18, 2026 at 9:15am UTC

We’re currently experiencing several issues that are directly affecting our services and your experience on the website.
We sincerely apologize for the inconvenience and appreciate your patience during this time.
Our team is actively working to identify and resolve these problems as quickly as possible and restore full functionality. We’re committed to getting everything back to normal as soon as we can.